<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3626593121824678",
    enable_page_level_ads: true
  });
</script>
    <title>Homecoming sucked - The Criterion</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://thecrite.com/coloradomesau/xmlrpc.php" />
    <meta property="og:image" content="http://thecrite.com/coloradomesau/wp-content/uploads/IMG_3298-e1509298013677.jpg" /><meta name="author" content="Matt Kennedy">

<!-- This site is optimized with the Yoast SEO plugin v5.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://thecrite.com/coloradomesau/homecoming-sucked/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Homecoming sucked - The Criterion" />
<meta property="og:description" content="Wait—there was a homecoming this year? It seems like the majority of the student body at Colorado Mesa University was unaware there was a homecoming week until the end of the weekend and it was too late. I am just going to come out and say it: homecoming was terrible. It was a very long &hellip;" />
<meta property="og:url" content="http://thecrite.com/coloradomesau/homecoming-sucked/" />
<meta property="og:site_name" content="The Criterion" />
<meta property="article:section" content="Opinions" />
<meta property="article:published_time" content="2017-11-02T06:00:30+00:00" />
<meta property="article:modified_time" content="2017-11-02T10:02:24+00:00" />
<meta property="og:updated_time" content="2017-11-02T10:02:24+00:00" />
<meta property="og:image" content="http://thecrite.com/coloradomesau/wp-content/uploads/IMG_3298-e1509298013677.jpg" />
<meta property="og:image:width" content="3000" />
<meta property="og:image:height" content="2000" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Wait—there was a homecoming this year? It seems like the majority of the student body at Colorado Mesa University was unaware there was a homecoming week until the end of the weekend and it was too late. I am just going to come out and say it: homecoming was terrible. It was a very long [&hellip;]" />
<meta name="twitter:title" content="Homecoming sucked - The Criterion" />
<meta name="twitter:image" content="http://thecrite.com/coloradomesau/wp-content/uploads/IMG_3298-e1509298013677.jpg" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/thecrite.com\/coloradomesau\/","name":"The Criterion","potentialAction":{"@type":"SearchAction","target":"http:\/\/thecrite.com\/coloradomesau\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/thecrite.com\/coloradomesau\/homecoming-sucked\/","sameAs":[],"@id":"#organization","name":"The Criterion","logo":"http:\/\/thecrite.com\/coloradomesau\/wp-content\/uploads\/2017\/01\/logo.jpg"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Criterion &raquo; Feed" href="http://thecrite.com/coloradomesau/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Criterion &raquo; Comments Feed" href="http://thecrite.com/coloradomesau/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Criterion &raquo; Homecoming sucked Comments Feed" href="http://thecrite.com/coloradomesau/homecoming-sucked/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/thecrite.com\/coloradomesau\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='breaking-nt-style-css'  href='http://thecrite.com/coloradomesau/wp-content/plugins/breaking-news-ticker/assets/css/ticker-style.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://thecrite.com/coloradomesau/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='es-widget-css-css'  href='http://thecrite.com/coloradomesau/wp-content/plugins/email-subscribers/widget/es-widget.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='media-credit-css'  href='http://thecrite.com/coloradomesau/wp-content/plugins/media-credit/public/css/media-credit.css?ver=3.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://thecrite.com/coloradomesau/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.4.6.2' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300&#038;ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Roboto+Slab%3A400%2C700&#038;ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='newsletter-subscription-css'  href='http://thecrite.com/coloradomesau/wp-content/plugins/newsletter/subscription/style.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://thecrite.com/coloradomesau/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://thecrite.com/coloradomesau/wp-content/themes/Newspaper/style.css?ver=7.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://thecrite.com/coloradomesau/wp-content/themes/Newspaper/includes/demos/politics/demo_style.css?ver=7.6.1' type='text/css' media='all' />
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/plugins/breaking-news-ticker/assets/js/newsTicker.min.js?ver=1'></script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/plugins/breaking-news-ticker/assets/js/jquery.easing.min.js?ver=1'></script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.4.6.2'></script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.4.6.2'></script>
<link rel='https://api.w.org/' href='http://thecrite.com/coloradomesau/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://thecrite.com/coloradomesau/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://thecrite.com/coloradomesau/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.3" />
<link rel='shortlink' href='http://thecrite.com/coloradomesau/?p=8211' />
<link rel="alternate" type="application/json+oembed" href="http://thecrite.com/coloradomesau/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthecrite.com%2Fcoloradomesau%2Fhomecoming-sucked%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://thecrite.com/coloradomesau/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthecrite.com%2Fcoloradomesau%2Fhomecoming-sucked%2F&#038;format=xml" />
<style type="text/css">

	.breaking-news-ticker {
		border-radius: 0px;
		border-style: solid;
		border-width: 0px;
    	border-color: #222222;
    	background-color: #dd3333;
	}

	.breaking-news-ticker ul li a,
	.breaking-news-ticker ul li a:link {
		color: #000000;
		font-size: 16px;
	}

	div.breaking-news-ticker .breaking-news-ticker-title {
		font-size: 15px;
		color: #000000;
		background-color: #dd3333;
	}

	div.breaking-news-ticker .breaking-news-ticker-title span {
    	border-color: transparent transparent transparent #dd3333;
	}
	
	.breaking-news-ticker .controls {
   		top: 5px;
	}

	.breaking-news-ticker .entry-meta {
		color:#000000;
	}

	.breaking-news-ticker .controls span {
    	background-color: #000000	}

</style><style type="text/css" media="screen">.menu-item.hide_this_item{ display:none !important; }</style><link rel="apple-touch-icon" sizes="180x180" href="/coloradomesau/wp-content/uploads/fbrfg/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/coloradomesau/wp-content/uploads/fbrfg/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/coloradomesau/wp-content/uploads/fbrfg/favicon-16x16.png">
<link rel="manifest" href="/coloradomesau/wp-content/uploads/fbrfg/manifest.json">
<link rel="mask-icon" href="/coloradomesau/wp-content/uploads/fbrfg/safari-pinned-tab.svg" color="#5bbad5">
<link rel="shortcut icon" href="/coloradomesau/wp-content/uploads/fbrfg/favicon.ico">
<meta name="msapplication-config" content="/coloradomesau/wp-content/uploads/fbrfg/browserconfig.xml">
<meta name="theme-color" content="#ffffff"><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://thecrite.com/coloradomesau/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><meta name="generator" content="Powered by Slider Revolution 5.4.6.2 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />

<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .post img";
var td_ajax_url="http:\/\/thecrite.com\/coloradomesau\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.6.1";
var td_get_template_directory_uri="http:\/\/thecrite.com\/coloradomesau\/wp-content\/themes\/Newspaper";
var tds_snap_menu="";
var tds_logo_on_sticky="";
var tds_header_style="10";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#a33535";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script type="text/javascript">function setREVStartSize(e){
				try{ var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;					
					if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
				}catch(d){console.log("Failure at Presize of Slider:"+d)}
			};</script>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/plugins/wp-spamshield/js/jscripts.php'></script> 
</head>

<body class="post-template-default single single-post postid-8211 single-format-standard homecoming-sucked td-politics single_template_8 wpb-js-composer js-comp-ver-5.0.1 vc_responsive td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/cmucriterion/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="mailto:criterion@coloradomesa.edu" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/CMU_Criterion" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-menu-container"><ul id="menu-menu" class="td-mobile-main-menu"><li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-first menu-item-10"><a href="http://thecrite.com/coloradomesau/category/news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-3079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3079"><a href="http://thecrite.com/coloradomesau/category/news/campus/">Campus</a></li>
	<li id="menu-item-3017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3017"><a href="http://thecrite.com/coloradomesau/category/news/asg/">Associated Student Government</a></li>
	<li id="menu-item-3087" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3087"><a href="http://thecrite.com/coloradomesau/category/news/blotter/">Blotter</a></li>
	<li id="menu-item-3080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3080"><a href="http://thecrite.com/coloradomesau/category/news/local/">Local</a></li>
</ul>
</li>
<li id="menu-item-4475" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4475"><a href="http://thecrite.com/coloradomesau/sports/">Sports<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-3036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3036"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/">Men&#8217;s Sports<i class="td-icon-menu-right td-element-after"></i></a>
	<ul  class="sub-menu">
		<li id="menu-item-3037" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3037"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/baseball/">Baseball</a></li>
		<li id="menu-item-3038" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3038"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/basketball/">Basketball</a></li>
		<li id="menu-item-3039" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3039"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/cross-country/">Cross Country</a></li>
		<li id="menu-item-3040" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3040"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/football/">Football</a></li>
		<li id="menu-item-3041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3041"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/golf/">Golf</a></li>
		<li id="menu-item-3042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3042"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/lacrosse/">Lacrosse</a></li>
		<li id="menu-item-3043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3043"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/soccer/">Soccer</a></li>
		<li id="menu-item-3044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3044"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/swimmingdiving/">Swimming/Diving</a></li>
		<li id="menu-item-3045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3045"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/tennis/">Tennis</a></li>
		<li id="menu-item-3046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3046"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/track-field/">Track &#038; Field</a></li>
		<li id="menu-item-3047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3047"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/wrestling/">Wrestling</a></li>
	</ul>
</li>
	<li id="menu-item-3048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3048"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/">Women&#8217;s Sports<i class="td-icon-menu-right td-element-after"></i></a>
	<ul  class="sub-menu">
		<li id="menu-item-3049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3049"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/basketball-womens-sports/">Basketball</a></li>
		<li id="menu-item-3050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3050"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/cheerleading/">Cheerleading</a></li>
		<li id="menu-item-3051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3051"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/cross-country-womens-sports/">Cross Country</a></li>
		<li id="menu-item-3052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3052"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/golf-womens-sports/">Golf</a></li>
		<li id="menu-item-3053" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3053"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/lacrosse-womens-sports/">Lacrosse</a></li>
		<li id="menu-item-3054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3054"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/soccer-womens-sports/">Soccer</a></li>
		<li id="menu-item-3055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3055"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/softball/">Softball</a></li>
		<li id="menu-item-3056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3056"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/swimmingdiving-womens-sports/">Swimming/Diving</a></li>
		<li id="menu-item-3057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3057"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/tennis-womens-sports/">Tennis</a></li>
		<li id="menu-item-3058" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3058"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/track-field-womens-sports/">Track &#038; Field</a></li>
		<li id="menu-item-3059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3059"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/volleyball/">Volleyball</a></li>
	</ul>
</li>
	<li id="menu-item-4479" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4479"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/">Club Sports<i class="td-icon-menu-right td-element-after"></i></a>
	<ul  class="sub-menu">
		<li id="menu-item-4480" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4480"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/alpine-skiing/">Alpine Skiing</a></li>
		<li id="menu-item-4481" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4481"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/hockey/">Ice Hockey</a></li>
		<li id="menu-item-4482" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4482"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/mens-rugby/">Men&#8217;s Rugby</a></li>
		<li id="menu-item-4485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4485"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/womens-rugby/">Women&#8217;s Rugby</a></li>
		<li id="menu-item-4483" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4483"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/nordic-skiing/">Nordic Skiing</a></li>
		<li id="menu-item-4484" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4484"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/rodeo/">Rodeo</a></li>
	</ul>
</li>
	<li id="menu-item-4691" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4691"><a href="http://thecrite.com/coloradomesau/category/sports/opinion/">Opinion</a></li>
</ul>
</li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-12"><a href="http://thecrite.com/coloradomesau/category/opinions/">Opinions<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-3020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3020"><a href="http://thecrite.com/coloradomesau/category/opinions/columns/">Columns<i class="td-icon-menu-right td-element-after"></i></a>
	<ul  class="sub-menu">
		<li id="menu-item-7653" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7653"><a href="http://thecrite.com/coloradomesau/category/opinions/columns/and-into-the-forest-i-go/">And Into The Forest I Go</a></li>
		<li id="menu-item-7673" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7673"><a href="http://thecrite.com/coloradomesau/category/opinions/columns/collegiate-cooking/">Collegiate Cooking</a></li>
		<li id="menu-item-6261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6261"><a href="http://thecrite.com/coloradomesau/category/opinions/columns/my-wine-ate-my-homework/">My Wine Ate My Homework</a></li>
		<li id="menu-item-4566" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4566"><a href="http://thecrite.com/coloradomesau/category/opinions/columns/trainer-talk/">Trainer Talk</a></li>
	</ul>
</li>
	<li id="menu-item-912" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-912"><a href="http://thecrite.com/coloradomesau/category/editorials/">Editorials</a></li>
	<li id="menu-item-3088" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3088"><a href="http://thecrite.com/coloradomesau/category/opinions/letters-to-the-editor/">Letters to the Editor</a></li>
</ul>
</li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13"><a href="http://thecrite.com/coloradomesau/category/artlife/">Art &#038; Life<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-4782" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4782"><a href="http://thecrite.com/coloradomesau/category/artlife/comics/">Comics<i class="td-icon-menu-right td-element-after"></i></a>
	<ul  class="sub-menu">
		<li id="menu-item-4784" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4784"><a href="http://thecrite.com/coloradomesau/category/artlife/comics/sphere-town/">Sphere Town</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-4323" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4323"><a href="http://thecrite.com/coloradomesau/contact-us/">Contact us<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-4444" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4444"><a href="http://thecrite.com/coloradomesau/contact-us/staff/">Staff</a></li>
	<li id="menu-item-5312" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5312"><a href="http://thecrite.com/coloradomesau/advertising-2">Advertising</a></li>
</ul>
</li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://thecrite.com/coloradomesau/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10">

	<div class="td-header-top-menu-full">
		<div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Tuesday, November 7, 2017
            </div>
        </div>
    </div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/cmucriterion/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="mailto:criterion@coloradomesa.edu" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/CMU_Criterion" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->
		</div>
	</div>

    <div class="td-banner-wrap-full td-logo-wrap-full ">
        <div class="td-header-sp-logo">
                <span class="td-logo-text-container">
		<a class="td-logo-wrap" href="http://thecrite.com/coloradomesau/">
							<span class="td-logo-text">THE CRITERION</span>
						<span class="td-tagline-text">THE VOICE OF COLORADO MESA UNIVERSITY SINCE 1931</span>
		</a>
    </span>
	        </div>
    </div>

	<div class="td-header-menu-wrap-full">
		<div class="td-header-menu-wrap td-header-gradient">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
            </div>
    <div class="menu-menu-container"><ul id="menu-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-10"><a href="http://thecrite.com/coloradomesau/category/news/">News</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3079"><a href="http://thecrite.com/coloradomesau/category/news/campus/">Campus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3017"><a href="http://thecrite.com/coloradomesau/category/news/asg/">Associated Student Government</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3087"><a href="http://thecrite.com/coloradomesau/category/news/blotter/">Blotter</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3080"><a href="http://thecrite.com/coloradomesau/category/news/local/">Local</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-4475"><a href="http://thecrite.com/coloradomesau/sports/">Sports</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-3036"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/">Men&#8217;s Sports</a>
	<ul  class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3037"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/baseball/">Baseball</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3038"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/basketball/">Basketball</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3039"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/cross-country/">Cross Country</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3040"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/football/">Football</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3041"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/golf/">Golf</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3042"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/lacrosse/">Lacrosse</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3043"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/soccer/">Soccer</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3044"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/swimmingdiving/">Swimming/Diving</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3045"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/tennis/">Tennis</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3046"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/track-field/">Track &#038; Field</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3047"><a href="http://thecrite.com/coloradomesau/category/sports/mens-sports/wrestling/">Wrestling</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-3048"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/">Women&#8217;s Sports</a>
	<ul  class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3049"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/basketball-womens-sports/">Basketball</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3050"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/cheerleading/">Cheerleading</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3051"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/cross-country-womens-sports/">Cross Country</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3052"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/golf-womens-sports/">Golf</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3053"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/lacrosse-womens-sports/">Lacrosse</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3054"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/soccer-womens-sports/">Soccer</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3055"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/softball/">Softball</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3056"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/swimmingdiving-womens-sports/">Swimming/Diving</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3057"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/tennis-womens-sports/">Tennis</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3058"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/track-field-womens-sports/">Track &#038; Field</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3059"><a href="http://thecrite.com/coloradomesau/category/sports/womens-sports/volleyball/">Volleyball</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-4479"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/">Club Sports</a>
	<ul  class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4480"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/alpine-skiing/">Alpine Skiing</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4481"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/hockey/">Ice Hockey</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4482"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/mens-rugby/">Men&#8217;s Rugby</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4485"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/womens-rugby/">Women&#8217;s Rugby</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4483"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/nordic-skiing/">Nordic Skiing</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4484"><a href="http://thecrite.com/coloradomesau/category/sports/club-sports/rodeo/">Rodeo</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4691"><a href="http://thecrite.com/coloradomesau/category/sports/opinion/">Opinion</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-12"><a href="http://thecrite.com/coloradomesau/category/opinions/">Opinions</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-3020"><a href="http://thecrite.com/coloradomesau/category/opinions/columns/">Columns</a>
	<ul  class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7653"><a href="http://thecrite.com/coloradomesau/category/opinions/columns/and-into-the-forest-i-go/">And Into The Forest I Go</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7673"><a href="http://thecrite.com/coloradomesau/category/opinions/columns/collegiate-cooking/">Collegiate Cooking</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6261"><a href="http://thecrite.com/coloradomesau/category/opinions/columns/my-wine-ate-my-homework/">My Wine Ate My Homework</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4566"><a href="http://thecrite.com/coloradomesau/category/opinions/columns/trainer-talk/">Trainer Talk</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-912"><a href="http://thecrite.com/coloradomesau/category/editorials/">Editorials</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3088"><a href="http://thecrite.com/coloradomesau/category/opinions/letters-to-the-editor/">Letters to the Editor</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-13"><a href="http://thecrite.com/coloradomesau/category/artlife/">Art &#038; Life</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-4782"><a href="http://thecrite.com/coloradomesau/category/artlife/comics/">Comics</a>
	<ul  class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4784"><a href="http://thecrite.com/coloradomesau/category/artlife/comics/sphere-town/">Sphere Town</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-4323"><a href="http://thecrite.com/coloradomesau/contact-us/">Contact us</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-4444"><a href="http://thecrite.com/coloradomesau/contact-us/staff/">Staff</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-5312"><a href="http://thecrite.com/coloradomesau/advertising-2">Advertising</a></li>
</ul>
</li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://thecrite.com/coloradomesau/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>			</div>
		</div>
	</div>

    <div class="td-banner-wrap-full td-banner-bg">
        <div class="td-container-header td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div><article id="post-8211" class="td-post-template-8 post-8211 post type-post status-publish format-standard has-post-thumbnail hentry category-opinions" itemscope itemtype="http://schema.org/Article">
    <div class="td-post-header td-image-gradient-style8">
        <div class="td-crumb-container"><div class="entry-crumbs" itemscope itemtype="http://schema.org/BreadcrumbList"><span class="td-bred-first"><a href="http://thecrite.com/coloradomesau/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemprop="itemListElement" itemtype="http://schema.org/ListItem">
                               <a title="View all posts in Opinions" class="entry-crumb" itemscope itemprop="item" itemtype="http://schema.org/Thing" href="http://thecrite.com/coloradomesau/category/opinions/">
                                  <span itemprop="name">Opinions</span>    </a>    <meta itemprop="position" content = "1"></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Homecoming sucked</span></div></div>

        <div class="td-post-header-holder">

            <header class="td-post-title">

                <ul class="td-category"><li class="entry-category"><a  href="http://thecrite.com/coloradomesau/category/opinions/">Opinions</a></li></ul>                <h1 class="entry-title">Homecoming sucked</h1>

                                    <p class="td-post-sub-title">Are we supposed to accept the mediocrity because we're a division II school?</p>
                
                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="http://thecrite.com/coloradomesau/author/mkennedy/">Matt Kennedy</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-11-02T06:00:30+00:00" >November 2, 2017</time></span>                    <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-8211">922</span></div>                    <div class="td-post-comments"><a href="http://thecrite.com/coloradomesau/homecoming-sucked/#comments"><i class="td-icon-comments"></i>2</a></div>                </div>

            </header>
        </div>
    </div>

<div class="td-post-template-8-box">
    <div class="td-container">
        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <div class="td-post-sharing td-post-sharing-top ">
				<div class="td-default-sharing">
		            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fthecrite.com%2Fcoloradomesau%2Fhomecoming-sucked%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
		            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Homecoming+sucked&url=http%3A%2F%2Fthecrite.com%2Fcoloradomesau%2Fhomecoming-sucked%2F&via=The+Criterion"  ><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
		            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://thecrite.com/coloradomesau/homecoming-sucked/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
		            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://thecrite.com/coloradomesau/homecoming-sucked/&amp;media=http://thecrite.com/coloradomesau/wp-content/uploads/IMG_3298-e1509298013677.jpg&description=Homecoming+sucked" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
		            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Homecoming+sucked%20-%20http%3A%2F%2Fthecrite.com%2Fcoloradomesau%2Fhomecoming-sucked%2F" ><i class="td-icon-whatsapp"></i></a>
	            </div></div>

    <div class="td-post-content">
        <p><span style="font-weight: 400;">Wait—there was a homecoming this year? It seems like the majority of the student body at Colorado Mesa University was unaware there was a homecoming week until the end of the weekend and it was too late. </span></p>
<p><span style="font-weight: 400;">I am just going to come out and say it: homecoming was terrible. It was a very long week with underwhelming events that portrayed the lackadaisical effort by the school to convey school spirit. </span></p>
<p><span style="font-weight: 400;">First and foremost, the first three days of homecoming week consisted of events that are similar to those that take place on the campus on a regular basis. The Programming Activities Council put on a cookie decorating event the second day of homecoming week, but how was it any different or more “spirited” than a pancake Friday, which is held on a normal basis in the University Center? </span></p>
<p><span style="font-weight: 400;">Homecoming is supposed to represent school spirit at its finest: everyone in the student body wearing their school colors and coming together as a community throughout the week, expressing their pride in attending the university they are paying thousands of dollars to attend.  </span></p>
<figure class="wp-caption alignleft" style="width: 300px"><div class="media-credit-container alignleft" style="width: 300px"><a href="http://thecrite.com/coloradomesau/__trashed-19/img_3230/" rel="attachment wp-att-8180"><img class="size-medium wp-image-8180" src="http://thecrite.com/coloradomesau/wp-content/uploads/IMG_3230-300x200.jpg" alt="" width="300" height="200" /></a><span class="media-credit"><a href="http://thecrite.com/coloradomesau/author/lvader/">Lucas Vader</a> | The Criterion</span></div></figure>
<p><span style="font-weight: 400;">I did not pay thousands of dollars to get a free t-shirt and a caramel apple and expect to feel satisfied with my decision to attend this school.   </span></p>
<p><span style="font-weight: 400;">But it’s all okay, right? We are supposed to okay with mediocrity and accept that CMU is “just a Division II school.” Therefore, students shouldn’t expect much. That’s what we are supposed to think.  </span></p>
<p><span style="font-weight: 400;">The first event of the week that actually &#8220;spirit-filled&#8221; was the carnival and the bonfire which were at the end of the week. But, the carnival was the exact same as last year, except this year it felt more washed up and boring. Bull riding, trampoline jumping, inflatable boxing ring, food. Sounds fun right? Maybe for 20 minutes, because that is how long it took to complete the activities. For the remaining of the two hours, everyone either left or stood around bored.  </span></p>
<p><span style="font-weight: 400;">The carnival and the bonfire were supposed to portray the end of a very successful week and get the students ready for the exciting football game the next day, which the students should be excited to attend and support their team. </span></p>
<p><span style="font-weight: 400;">The matter of the fact is, even though the bonfire was an appealing thing to look at and the music was a nice touch, that should not have been the only “successful” thing during a whole week of events. </span></p>
<p><span style="font-weight: 400;">The football game was no better. Attendance was below the average rate and the tailgate was nothing special despite the special occasion. CMU gets one homecoming game per year, and this year it felt as if it was pushed under the rug because it was too ugly to look at.  </span></p>
<p><span style="font-weight: 400;">I refuse to accept the ploy of below-average results from above-average hype and that is all homecoming was at CMU—all hype and no delivery.   </span></p>
<p><span style="font-weight: 400;">CMU is a great school with outstanding staff and it’s going to have a bright future. But the fact that people have trouble accepting that “CMU is boring,” need to open their eyes to see the laziness and below standard effort that make something as simple as homecoming feel so forced and washed up.  </span></p>
    </div>


    <footer>
                
        <div class="td-post-source-tags">
                                </div>

        <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fthecrite.com%2Fcoloradomesau%2Fhomecoming-sucked%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Homecoming+sucked&url=http%3A%2F%2Fthecrite.com%2Fcoloradomesau%2Fhomecoming-sucked%2F&via=The+Criterion"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://thecrite.com/coloradomesau/homecoming-sucked/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://thecrite.com/coloradomesau/homecoming-sucked/&amp;media=http://thecrite.com/coloradomesau/wp-content/uploads/IMG_3298-e1509298013677.jpg&description=Homecoming+sucked" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Homecoming+sucked%20-%20http%3A%2F%2Fthecrite.com%2Fcoloradomesau%2Fhomecoming-sucked%2F" ><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://thecrite.com/coloradomesau/homecoming-sucked/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://thecrite.com/coloradomesau/homecoming-sucked/" data-text="Homecoming sucked" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://thecrite.com/coloradomesau/official-north-avenue-forever/">It&#8217;s official: North Avenue Forever</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://thecrite.com/coloradomesau/homecoming-didnt-suck/">Homecoming DIDN&#8217;T suck</a></div></div></div>        <div class="author-box-wrap"><a href="http://thecrite.com/coloradomesau/author/mkennedy/"><img src="http://thecrite.com/coloradomesau/wp-content/uploads/DSC0858-1-e1504531220637-96x96.jpg" width="96" height="96" alt="Matt Kennedy" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="http://thecrite.com/coloradomesau/author/mkennedy/">Matt Kennedy</a></span></div><div class="td-author-description">Matt Kennedy is a sophomore mass communication major from Colorado Springs. He is in his second year with The Criterion where he was a writer all of his freshman year and is now the assistant sports editor. Kennedy went to Doherty High School where he wrote for his school paper for three years and he aspires to continue in the sports journalism field after graduation to pursue a career as a sportscaster.</div><div class="td-author-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="mailto:mjkennedy@mavs.coloradomesa.edu" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span></div><div class="clearfix"></div></div></div>	    <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Matt Kennedy"></span><meta itemprop="datePublished" content="2017-11-02T06:00:30+00:00"><meta itemprop="dateModified" content="2017-11-02T10:02:24+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://thecrite.com/coloradomesau/homecoming-sucked/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content=""></span><meta itemprop="name" content="The Criterion"></span><meta itemprop="headline " content="Homecoming sucked"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://thecrite.com/coloradomesau/wp-content/uploads/IMG_3298-e1509298013677.jpg"><meta itemprop="width" content="3000"><meta itemprop="height" content="2000"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_2_5a01bc6dd1525_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_2_5a01bc6dd1525" ><script>var block_td_uid_2_5a01bc6dd1525 = new tdBlock();
block_td_uid_2_5a01bc6dd1525.id = "td_uid_2_5a01bc6dd1525";
block_td_uid_2_5a01bc6dd1525.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_2_5a01bc6dd1525_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_2_5a01bc6dd1525_rand","live_filter":"cur_post_same_categories","live_filter_cur_post_id":8211,"live_filter_cur_post_author":"44"}';
block_td_uid_2_5a01bc6dd1525.td_column_number = "3";
block_td_uid_2_5a01bc6dd1525.block_type = "td_block_related_posts";
block_td_uid_2_5a01bc6dd1525.post_count = "3";
block_td_uid_2_5a01bc6dd1525.found_posts = "282";
block_td_uid_2_5a01bc6dd1525.header_color = "";
block_td_uid_2_5a01bc6dd1525.ajax_pagination_infinite_stop = "";
block_td_uid_2_5a01bc6dd1525.max_num_pages = "94";
tdBlocksArray.push(block_td_uid_2_5a01bc6dd1525);
</script><h4 class="td-related-title"><a id="td_uid_3_5a01bc6dd5d13" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_2_5a01bc6dd1525" href="#">RELATED ARTICLES</a><a id="td_uid_4_5a01bc6dd5d56" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_2_5a01bc6dd1525" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_2_5a01bc6dd1525 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://thecrite.com/coloradomesau/carving-the-abs/" rel="bookmark" title="Carving the abs"><img width="218" height="150" class="entry-thumb" src="http://thecrite.com/coloradomesau/wp-content/uploads/IMG_0511-218x150.jpg" srcset="http://thecrite.com/coloradomesau/wp-content/uploads/IMG_0511-218x150.jpg 218w, http://thecrite.com/coloradomesau/wp-content/uploads/IMG_0511-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Carving the abs"/></a></div>                <a href="http://thecrite.com/coloradomesau/category/opinions/columns/" class="td-post-category">Columns</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://thecrite.com/coloradomesau/carving-the-abs/" rel="bookmark" title="Carving the abs">Carving the abs</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://thecrite.com/coloradomesau/getting-top-garfield/" rel="bookmark" title="Getting on top of Garfield"><img width="218" height="150" class="entry-thumb" src="http://thecrite.com/coloradomesau/wp-content/uploads/20171022161626_IMG_1116-218x150.jpg" srcset="http://thecrite.com/coloradomesau/wp-content/uploads/20171022161626_IMG_1116-218x150.jpg 218w, http://thecrite.com/coloradomesau/wp-content/uploads/20171022161626_IMG_1116-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Getting on top of Garfield"/></a></div>                <a href="http://thecrite.com/coloradomesau/category/opinions/columns/and-into-the-forest-i-go/" class="td-post-category">And Into The Forest I Go</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://thecrite.com/coloradomesau/getting-top-garfield/" rel="bookmark" title="Getting on top of Garfield">Getting on top of Garfield</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://thecrite.com/coloradomesau/five-guys-meet-tinder/" rel="bookmark" title="The five guys you meet on Tinder"><img width="218" height="150" class="entry-thumb" src="http://thecrite.com/coloradomesau/wp-content/uploads/fullsizeoutput_1a11-218x150.jpeg" srcset="http://thecrite.com/coloradomesau/wp-content/uploads/fullsizeoutput_1a11-218x150.jpeg 218w, http://thecrite.com/coloradomesau/wp-content/uploads/fullsizeoutput_1a11-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="The five guys you meet on Tinder"/></a></div>                <a href="http://thecrite.com/coloradomesau/category/opinions/columns/" class="td-post-category">Columns</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://thecrite.com/coloradomesau/five-guys-meet-tinder/" rel="bookmark" title="The five guys you meet on Tinder">The five guys you meet on Tinder</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5a01bc6dd1525" data-td_block_id="td_uid_2_5a01bc6dd1525"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_2_5a01bc6dd1525" data-td_block_id="td_uid_2_5a01bc6dd1525"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
	<div class="comments" id="comments">
        
            <div class="td-comments-title-wrap ">
                <h4 class="td-comments-title block-title"><span>2 COMMENTS</span></h4>
            </div>

		        <ol class="comment-list ">
                            <li class="comment " id="comment-648">
			<article>
	            <footer>
                    <img src="http://0.gravatar.com/avatar/9b80ddc0808db47aa73ae381bae5d196?s=50&#038;d=mm&#038;r=g" width="50" height="50" alt="" class="avatar avatar-50 wp-user-avatar wp-user-avatar-50 photo avatar-default" />                    <cite>Jorge Jacquez</cite>

                    <a class="comment-link" href="#comment-648">
                        <time pubdate="1509738056">November 3, 2017 at 1:40 pm</time>
                    </a>
                </footer>

                <div class="comment-content">
                    <p>How about instead of pointing out the problems, you could better respond to this issue by stating solutions to the events to make them better. Even perhaps the Criterion could offer help to the organizations to make a more fun and enjoyable event.  My question to the Criterion is how many school events do they help with and support?  Of course if one is successful and or unenjoyable they are the first to write about it, but it&#8217;s easy to write about something that you put no help into.  Perhaps issues were faced by the organizations that hosted and brought to life these activities that the Criterion doesn&#8217;t care to take into account.</p>
                </div>

	            <div class="comment-meta" id="comment-648">
                    <a rel='nofollow' class='comment-reply-link' href='http://thecrite.com/coloradomesau/homecoming-sucked/?replytocom=648#respond' onclick='return addComment.moveForm( "comment-648", "648", "respond", "8211" )' aria-label='Reply to Jorge Jacquez'>Reply</a>                </div>
            </article>
    </li><!-- #comment-## -->
        <li class="comment " id="comment-649">
			<article>
	            <footer>
                    <img src="http://0.gravatar.com/avatar/9b80ddc0808db47aa73ae381bae5d196?s=50&#038;d=mm&#038;r=g" width="50" height="50" alt="" class="avatar avatar-50 wp-user-avatar wp-user-avatar-50 photo avatar-default" />                    <cite>Jorge Jacquez</cite>

                    <a class="comment-link" href="#comment-649">
                        <time pubdate="1509738172">November 3, 2017 at 1:42 pm</time>
                    </a>
                </footer>

                <div class="comment-content">
                    <p>How about instead of pointing out the problems, you could better respond to this issue by stating solutions to the events to make them better. Even perhaps the Criterion could offer help to the organizations to make a more fun and enjoyable event.  My question to the Criterion is how many school events do they help with and support?  Of course if one is successful and or unenjoyable they are the first to write about it, but it&#8217;s easy to write about something that you put no help into.  Pehaps issues were faced by the organizations that hosted and brought to life these activities that the Criterion doesn&#8217;t care to take into account.</p>
                </div>

	            <div class="comment-meta" id="comment-649">
                    <a rel='nofollow' class='comment-reply-link' href='http://thecrite.com/coloradomesau/homecoming-sucked/?replytocom=649#respond' onclick='return addComment.moveForm( "comment-649", "649", "respond", "8211" )' aria-label='Reply to Jorge Jacquez'>Reply</a>                </div>
            </article>
    </li><!-- #comment-## -->
                </ol>
                <div class="comment-pagination">
                                                        </div>

            	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/coloradomesau/homecoming-sucked/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://thecrite.com/coloradomesau/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
                     </div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='8211' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ea904afc52" /></p>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="245"/></p>			</form>
			</div><!-- #respond -->
	    </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <div class="td_block_wrap td_block_20 td_block_widget td_uid_5_5a01bc6dde219_rand td-pb-border-top"  data-td-block-uid="td_uid_5_5a01bc6dde219" ><script>var block_td_uid_5_5a01bc6dde219 = new tdBlock();
block_td_uid_5_5a01bc6dde219.id = "td_uid_5_5a01bc6dde219";
block_td_uid_5_5a01bc6dde219.atts = '{"limit":"5","sort":"popular7","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"TRENDING NOW","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_5_5a01bc6dde219_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_5_5a01bc6dde219_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":""}';
block_td_uid_5_5a01bc6dde219.td_column_number = "1";
block_td_uid_5_5a01bc6dde219.block_type = "td_block_20";
block_td_uid_5_5a01bc6dde219.post_count = "5";
block_td_uid_5_5a01bc6dde219.found_posts = "1206";
block_td_uid_5_5a01bc6dde219.header_color = "#";
block_td_uid_5_5a01bc6dde219.ajax_pagination_infinite_stop = "";
block_td_uid_5_5a01bc6dde219.max_num_pages = "242";
tdBlocksArray.push(block_td_uid_5_5a01bc6dde219);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span>TRENDING NOW</span></h4></div><div id=td_uid_5_5a01bc6dde219 class="td_block_inner td-column-1">
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="http://thecrite.com/coloradomesau/cmu-purchases-party-house-evicts-residents/" rel="bookmark" title="CMU purchases party house, evicts residents"><img width="324" height="235" class="entry-thumb" src="http://thecrite.com/coloradomesau/wp-content/uploads/IMG_0233-324x235.jpg" alt="" title="CMU purchases party house, evicts residents"/></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="http://thecrite.com/coloradomesau/cmu-purchases-party-house-evicts-residents/" rel="bookmark" title="CMU purchases party house, evicts residents">CMU purchases party house, evicts residents</a></h3>                                <span class="td-post-author-name"><a href="http://thecrite.com/coloradomesau/author/awilliams/">Alec Williams</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-11-06T15:37:02+00:00" >November 6, 2017</time></span>                <div class="td-module-comments"><a href="http://thecrite.com/coloradomesau/cmu-purchases-party-house-evicts-residents/#comments">1</a></div>            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="http://thecrite.com/coloradomesau/sodexo-investigation/" rel="bookmark" title="Sodexo investigating employee who allegedly sent sexually threatening messages"><img width="324" height="235" class="entry-thumb" src="http://thecrite.com/coloradomesau/wp-content/uploads/IMG_0036-324x235.jpg" alt="" title="Sodexo investigating employee who allegedly sent sexually threatening messages"/></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="http://thecrite.com/coloradomesau/sodexo-investigation/" rel="bookmark" title="Sodexo investigating employee who allegedly sent sexually threatening messages">Sodexo investigating employee who allegedly sent sexually threatening messages</a></h3>                                <span class="td-post-author-name"><a href="http://thecrite.com/coloradomesau/author/awilliams/">Alec Williams</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-11-01T18:28:22+00:00" >November 1, 2017</time></span>                <div class="td-module-comments"><a href="http://thecrite.com/coloradomesau/sodexo-investigation/#comments">3</a></div>            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="http://thecrite.com/coloradomesau/highest-paid-professors-cmu/" rel="bookmark" title="The highest-paid professors at CMU"><img width="324" height="235" class="entry-thumb" src="http://thecrite.com/coloradomesau/wp-content/uploads/Steven-Norman-cropped-324x235.jpg" alt="" title="The highest-paid professors at CMU"/></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="http://thecrite.com/coloradomesau/highest-paid-professors-cmu/" rel="bookmark" title="The highest-paid professors at CMU">The highest-paid professors at CMU</a></h3>                                <span class="td-post-author-name"><a href="http://thecrite.com/coloradomesau/author/awilliams/">Alec Williams</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-11-01T06:00:36+00:00" >November 1, 2017</time></span>                <div class="td-module-comments"><a href="http://thecrite.com/coloradomesau/highest-paid-professors-cmu/#comments">2</a></div>            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="http://thecrite.com/coloradomesau/homecoming-sucked/" rel="bookmark" title="Homecoming sucked"><img width="324" height="235" class="entry-thumb" src="http://thecrite.com/coloradomesau/wp-content/uploads/IMG_3298-324x235.jpg" alt="" title="Homecoming sucked"/></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="http://thecrite.com/coloradomesau/homecoming-sucked/" rel="bookmark" title="Homecoming sucked">Homecoming sucked</a></h3>                                <span class="td-post-author-name"><a href="http://thecrite.com/coloradomesau/author/mkennedy/">Matt Kennedy</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-11-02T06:00:30+00:00" >November 2, 2017</time></span>                <div class="td-module-comments"><a href="http://thecrite.com/coloradomesau/homecoming-sucked/#comments">2</a></div>            </div>

        </div>

        
        <div class="td_module_mx3 td_module_wrap td-animation-stack">
            <div class="td-module-thumb"><a href="http://thecrite.com/coloradomesau/comfort-opinion-discomfort-thought/" rel="bookmark" title="Comfort of opinion, discomfort of thought"><img width="324" height="235" class="entry-thumb" src="http://thecrite.com/coloradomesau/wp-content/uploads/DSC0688-324x235.jpg" alt="" title="Comfort of opinion, discomfort of thought"/></a></div>
            <div class="td-module-meta-info">
                <h3 class="entry-title td-module-title"><a href="http://thecrite.com/coloradomesau/comfort-opinion-discomfort-thought/" rel="bookmark" title="Comfort of opinion, discomfort of thought">Comfort of opinion, discomfort of thought</a></h3>                                <span class="td-post-author-name"><a href="http://thecrite.com/coloradomesau/author/tfoster/">Tim Foster</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-10-30T12:31:09+00:00" >October 30, 2017</time></span>                <div class="td-module-comments"><a href="http://thecrite.com/coloradomesau/comfort-opinion-discomfort-thought/#respond">0</a></div>            </div>

        </div>

        </div></div> <!-- ./block --><aside class="widget widget_sp_image"><a href="https://apps.appmachine.com/criterion" target="_self" class="widget_sp_image-image-link"><img width="1408" height="2176" class="attachment-full" style="max-width: 100%;" src="http://thecrite.com/coloradomesau/wp-content/uploads/appad-1-pdf.jpg" /></a></aside><div class="td_block_wrap td_block_weather td_block_widget td_uid_6_5a01bc6e253a0_rand td-pb-border-top"  data-td-block-uid="td_uid_6_5a01bc6e253a0" ><div id=td_uid_6_5a01bc6e253a0 class="td-weather-wrap td_block_inner td-column-1"><!-- td weather source: cache -->
		<div class="td-weather-header">
			<div class="td-weather-city">81501</div>
			<div class="td-weather-condition">clear sky</div>
			<i class="td-location-icon td-icons-location"  data-block-uid="td_uid_6_5a01bc6e253a0"></i>
		</div>

		<div class="td-weather-set-location">
			<form class="td-manual-location-form" action="#" data-block-uid="td_uid_6_5a01bc6e253a0">
				<input id="td_uid_6_5a01bc6e253a0" class="td-location-set-input" type="text" name="location" value="" >
				<label>enter location</label>
			</form>
		</div>

		<div class="td-weather-temperature">
			<div class="td-weather-temp-wrap">
				<div class="td-weather-animated-icon">
					<span class="td_animation_sprite-27-100-80-0-0-1 clear-sky-n td-w-today-icon" data-td-block-uid="td_uid_6_5a01bc6e253a0"></span>
				</div>
				<div class="td-weather-now" data-block-uid="td_uid_6_5a01bc6e253a0">
					<span class="td-big-degrees">39.2</span>
					<span class="td-circle">&deg;</span>
					<span class="td-weather-unit">F</span>
				</div>
				<div class="td-weather-lo-hi">
					<div class="td-weather-degrees-wrap">
						<i class="td-up-icon td-icons-arrows-up"></i>
						<span class="td-small-degrees td-w-high-temp">39.2</span>
						<span class="td-circle">&deg;</span>
					</div>
					<div class="td-weather-degrees-wrap">
						<i class="td-down-icon td-icons-arrows-down"></i>
						<span class="td-small-degrees td-w-low-temp">39.2</span>
						<span class="td-circle">&deg;</span>
					</div>
				</div>
			</div>
		</div>

		<div class="td-weather-info-wrap">
			<div class="td-weather-information">
				<div class="td-weather-section-1">
					<i class="td-icons-drop"></i>
					<span class="td-weather-parameter td-w-today-humidity">69%</span>
				</div>
				<div class="td-weather-section-2">
					<i class="td-icons-wind"></i>
					<span class="td-weather-parameter td-w-today-wind-speed">2.2mph</span>
				</div>
				<div class="td-weather-section-3">
					<i class="td-icons-cloud"></i>
					<span class="td-weather-parameter td-w-today-clouds">1%</span>
				</div>
			</div>


			<div class="td-weather-week">
									<div class="td-weather-days">
						<div class="td-day-0">Wed</div>
						<div class="td-day-degrees">
							<span class="td-degrees-0">41</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-1">Thu</div>
						<div class="td-day-degrees">
							<span class="td-degrees-1">46</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-2">Fri</div>
						<div class="td-day-degrees">
							<span class="td-degrees-2">48</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-3">Sat</div>
						<div class="td-day-degrees">
							<span class="td-degrees-3">43</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
										<div class="td-weather-days">
						<div class="td-day-4">Sun</div>
						<div class="td-day-degrees">
							<span class="td-degrees-4">44</span>
							<span class="td-circle">&deg;</span>
						</div>
					</div>
								</div>
		</div>
		</div></div> <!-- ./block -->                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-post-template-8-box -->
</article> <!-- /.post -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-footer-template-13">
    <div class="td-container">
        <div class="td-pb-row">
            <div class="td-pb-span12">
                
                <div class="footer-social-wrap td-social-style-2">
                    
            <span class="td-social-icon-wrap">
                <a target="_blank" href="https://www.facebook.com/cmucriterion/" title="Facebook">
                    <i class="td-icon-font td-icon-facebook"></i>
                    <span class="td-social-name">Facebook</span>
                </a>
            </span>
            <span class="td-social-icon-wrap">
                <a target="_blank" href="mailto:criterion@coloradomesa.edu" title="Mail">
                    <i class="td-icon-font td-icon-mail-1"></i>
                    <span class="td-social-name">Mail</span>
                </a>
            </span>
            <span class="td-social-icon-wrap">
                <a target="_blank" href="https://twitter.com/CMU_Criterion" title="Twitter">
                    <i class="td-icon-font td-icon-twitter"></i>
                    <span class="td-social-name">Twitter</span>
                </a>
            </span>                </div>
            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-subfooter-menu"><li id="menu-item-3073" class="bp-menu bp-logout-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-3073"><a href="http://thecrite.com/coloradomesau/wp-login.php?action=logout&#038;_wpnonce=027121dfde">Log Out</a></li>
<li id="menu-item-3074" class="bp-menu bp-login-nav menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3074"><a href="http://thecrite.com/coloradomesau/wp-login.php">Log In</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; Colorado Mesa University 2017                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

<!-- analytics-code google analytics tracking code --><script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	ga('create', 'UA-85528153-1', 'auto');
	ga('send', 'pageview');

</script><!--  -->
<script type="text/javascript">
    jQuery(document).ready(function(){
        jQuery("#main-bnt").easyTicker({    
            direction: 'down',
            speed: 500,
            interval: 3000,
            height: 'auto',
            visible: 1,
            mousePause: 1,
            controls: {
                down: '#prev-btn',
                up: '#next-btn'
            }
         });
    });
</script>
    
<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='62af4e0930034b92830ab637684a9c7d';
hf4V='b2809649b063aa5f27a026b4f7556711';
cm4S="form[action='http://thecrite.com/coloradomesau/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form, .wpcf7-form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(e);return true;});$("#comment").attr({minlength:"15",maxlength:"15360"})});
/* ]]> */
</script> 


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.6.1 (rara)
        Deploy mode: deploy
        
        uid: 5a01bc6e28162
    -->

    <script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/thecrite.com\/coloradomesau\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var es_widget_notices = {"es_email_notice":"Please enter email address","es_incorrect_email":"Please provide a valid email address","es_load_more":"loading...","es_ajax_error":"Cannot create XMLHTTP instance","es_success_message":"Successfully Subscribed.","es_success_notice":"Your subscription was successful! Within a few minutes, kindly check the mail in your mailbox and confirm your subscription. If you can't see the mail in your mailbox, please check your spam folder.","es_email_exists":"Email Address already exists!","es_error":"Oops.. Unexpected error occurred.","es_invalid_email":"Invalid email address","es_try_later":"Please try after some time","es_problem_request":"There was a problem with the request"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/plugins/email-subscribers/widget/es-widget.js?ver=4.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var es_widget_page_notices = {"es_email_notice":"Please enter email address","es_incorrect_email":"Please provide a valid email address","es_load_more":"loading...","es_ajax_error":"Cannot create XMLHTTP instance","es_success_message":"Successfully Subscribed.","es_success_notice":"Your subscription was successful! Within a few minutes, kindly check the mail in your mailbox and confirm your subscription. If you can't see the mail in your mailbox, please check your spam folder.","es_email_exists":"Email Address already exists!","es_error":"Oops.. Unexpected error occurred.","es_invalid_email":"Invalid email address","es_try_later":"Please try after some time","es_problem_request":"There was a problem with the request"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/plugins/email-subscribers/widget/es-widget-page.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.6.1'></script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-includes/js/comment-reply.min.js?ver=4.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/plugins/newsletter/subscription/validate.js?ver=5.1.1'></script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/plugins/wp-spamshield/js/jscripts-ftr-min.js'></script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-includes/js/wp-embed.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://thecrite.com/coloradomesau/wp-content/plugins/akismet/_inc/form.js?ver=4.0'></script>

<!-- JS generated by theme -->

<script>
    


            

	            // if the theme has tdBackstr support, it means this already uses it
                if ( 'undefined' !== typeof window.tdBackstr ) {

                    (function(){
                        // the site background td-backstretch jquery object is dynamically added in DOM, and after any translation effects are applied over td-backstretch
                        var wrapper_image_jquery_obj = jQuery( '<div class=\'backstretch\'></div>' );
                        var image_jquery_obj = jQuery( '<img class=\'td-backstretch not-parallax\' src=\'http://thecrite.com/coloradomesau/wp-content/uploads/IMG_3298-e1509298013677.jpg\'>' );

                        wrapper_image_jquery_obj.append( image_jquery_obj );

                        jQuery( 'body' ).prepend( wrapper_image_jquery_obj );

                        var td_backstr_item = new tdBackstr.item();

                        td_backstr_item.wrapper_image_jquery_obj = wrapper_image_jquery_obj;
                        td_backstr_item.image_jquery_obj = image_jquery_obj;

	                    tdBackstr.add_item( td_backstr_item );

                    })();
                }

            
            

			
				jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_uid_6_5a01bc6e253a0","location":"81501","api_location":"Grand Junction","api_language":"en","today_icon":"clear-sky-n","today_icon_text":"clear sky","today_temp":[4,39.2],"today_humidity":69,"today_wind_speed":[3.6,2.2],"today_min":[4,39.2],"today_max":[4,39.2],"today_clouds":1,"current_unit":1,"forecast":[{"timestamp":1510164000,"day_temp":[5,41],"day_name":"Wed","owm_day_index":2},{"timestamp":1510250400,"day_temp":[8,46],"day_name":"Thu","owm_day_index":3},{"timestamp":1510336800,"day_temp":[9,48],"day_name":"Fri","owm_day_index":4},{"timestamp":1510423200,"day_temp":[6,43],"day_name":"Sat","owm_day_index":5},{"timestamp":1510509600,"day_temp":[7,44],"day_name":"Sun","owm_day_index":6}],"api_key":"849339ce83cba73963c74b390cba23dd"});
				});
			
			

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://thecrite.com/coloradomesau/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://thecrite.com/coloradomesau/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<script src="https://use.typekit.net/gyk4plb.js"></script>
<script>try{Typekit.load({ async: true });}catch(e){}</script>
</body>
</html>